problem with date and time text expander

Discussion, questions and support.
Post Reply
azim58
Posts: 2
Joined: Aug 10th, ’19, 09:20

Post by azim58 » Aug 10th, ’19, 09:44

The main thing that I use fastkeys for is to quickly enter a date and time stamp. In fastkeys, I setup a Text Expander command so that when I press "dt" (for the date) some text such as "2019 08 Aug 10 1140" will be written. I accomplished this by sending the following command: "%A_YYYY% %A_MM% %A_MMM% %A_DD% %A_Hour%%A_Min%". However, the problem is that very frequently it is as if the Shift key is held down for at least one of the characters even when I am not pressing the Shift key. So for example something like "2019 0* aug 10 1141" will be written. Then I have to go back and correct the wrong Shift key character, which somewhat defeats the purpose of the time saving feature. This problem does not happen every single time, but I would say that it occurs about 80-90% of the time. How can I fix this?
User avatar
Marko
Posts: 1016
Joined: Mar 2nd, ’13, 21:02

Post by Marko » Aug 10th, ’19, 17:06

This is certainly not normal. In which application do you experience this?

Try to introduce a small Key Delay in Preferences/Text Expander/Advanced and let me know if this helps.
azim58
Posts: 2
Joined: Aug 10th, ’19, 09:20

Post by azim58 » Aug 10th, ’19, 18:17

I experience this problem in any application. . anywhere where I type text. I followed your instructions, and I introduced a 10 ms delay. This appears to have fixed the problem. I just inserted a date more than 10 times in a row, and all of the dates were correct. This never would have been possible with my previous setup. The 10 ms delay is also still very fast. I don't really notice the delay. So I'm satisfied. Thanks!
Post Reply