Wordlist files folder

Discussion, questions and support.
Post Reply
User avatar
easycass
Posts: 20
Joined: May 24th, ’18, 03:28

Post by easycass » May 30th, ’18, 08:00

Hi there again, just another little one...

I have set the Wordlist file folder in General/Folders to D:\System\Resources\FastKeys\Wordlists\ and copied all the word list files there from the default location C:\Program Files (x86)\FastKeys\Wordlists\. The program is looking up my words in the new location and any new automatically learned words are going correctly to D:\System\Resources\FastKeys\Wordlists\Learned.txt.

However, when I activate the shortcut key, as specified in General/Shortcuts/Quick-add, to add a word straight into the Learn Wordlist File, the word is not being saved into D:\System\Resources\FastKeys\Wordlists\Learned.txt but is being saved into the original location C:\Program Files (x86)\FastKeys\Wordlists\Learned.txt.

Also, I noticed that words are not checked for duplicates when being put into the Learned.txt file. I can of course clear duplicates manually, but it would be great if it was automatic ;)

Just working through all the features, so I hope you don't mind that I am sending through a few 'findings'...

Cheers,
Cass.
User avatar
Marko
Posts: 812
Joined: Mar 2nd, ’13, 21:02

Post by Marko » May 30th, ’18, 15:55

After changing the wordlist folder, you need to copy or create a file in it. Then go to Preferences/Auto Complete/Auto Learning and select it from a drop-down list (Learn wordlist file).

When words are added using a Quick-add function they are not checked for duplicates. This will be resolved in the next release. ;)

Thanks for posting your findings and suggestions, this is highly appreciated and helps us improving the software. So please keep on... :D
User avatar
easycass
Posts: 20
Joined: May 24th, ’18, 03:28

Post by easycass » May 30th, ’18, 16:53

Hi Marko,

Hmmm, I did make sure that everything has been correctly set, but still I am finding that an automatically learned word goes into my specified new folder: D:\System\Resources\FastKeys\Wordlists\Learned.txt but a manually added word via short cut key goes into the original location C:\Program Files (x86)\FastKeys\Wordlists\Learned.txt.

So, I made a new file and something I noticed...

1) I tried created a new text file in D:\System\Resources\FastKeys\Wordlists\, calling that folder NewLearned.txt. I found that file and selected it in the drop-down menu at Preferences/Auto Learning/Learn wordlist file. All good so far.

2) I then entered a new word three times into Notepad so it would be auto-learned, and it went successfully into that new file on the D drive. No problems here either.

3) Then I type in a new word into Notepad, selected it and hit my keyboard shortcut to add the word manually, and what I noted was another NewLearned.txt file was created in C:\Program Files (x86)\FastKeys\Wordlists\, with that added word in it.

So, still a problem from my end... Haha, maybe my computers are just no good :shock:
User avatar
Marko
Posts: 812
Joined: Mar 2nd, ’13, 21:02

Post by Marko » May 31st, ’18, 07:14

I confirm, similar Quick-add issue as above - will be corrected in the next release. Thanks.
Post Reply