'The' Issue

Discussion, questions and support.
User avatar
easycass
Posts: 20
Joined: May 24th, ’18, 03:28

Post by easycass » May 28th, ’18, 17:46

Hi there,

So, here is an example of something that is happening, and I would like to know if it can be reproduced for someone else.. I came across it due to the fact that i usually type the letters 'teh' instead of 'the'. So, what I found is that under some circumstances, the 'teh' does not get corrected to 'the', as specified in the Text Expander 'Auto Correct English' file. Now it so happens that there is another word in the Auto Complete 'English Common Words', the word 'Tehran'.

Note, I have Text Expander option to 'Display Suggestions as you type' to off, and Auto Complete 'Minimum word length' set to 3.

As I understand it, as I type the letters 'teh', when I get to h, the word 'Tehran' is suggested, and if I press '1' or [Enter], it chooses Tehran. This works fine. But if instead of typing '1' or 'Enter' I type [Space]' it should go ahead and correct the 'teh' to 'the'. Well, it sometimes doesn't. Now, if I type 'teh' and follow that with a period, comma, or other delimeter instead of a [Space], then it works, well, sometimes.

So, let's see if I can demonstrate it. Try to do this test If you will. In Notepad, type the following: -

teh [Space] teh [Space] teh [Enter] [Space] teh [Space] teh [.] [Space] teh [.] [Space] teh [.] [Space] teh [Space]

When i do this, I get the result as follows: -

teh teh Tehran teh teh. the. the. teh

Now, I am trying this out with different combinations of other words, and get similar results - it is not 'the' and 'Tehran' specific :) Also, if I deselect the Auto Complete 'English Common Words' file, all seems to work for auto-correcting 'teh' to 'the' every time.

Anyone want to give it a try?
User avatar
Marko
Posts: 812
Joined: Mar 2nd, ’13, 21:02

Post by Marko » May 29th, ’18, 09:57

Thanks, unfortunately I cannot reproduce it, I tried on three computers and it always triggers "the".

Internally Text expansion should have a priority over Auto Complete so typing an ending character should always trigger the correction ("the"). It seems like on your computer this is not the case due to some specific combination of settings. Or do you use slower computer?
User avatar
easycass
Posts: 20
Joined: May 24th, ’18, 03:28

Post by easycass » May 29th, ’18, 10:18

Hi Marko,

Thank you for testing that. Actually, the computer I am on is hot off the press, the latest mobile beast you can get, with i7-7700HQ CPU, 32Gb 2400Mhz RAM, 1070 Max-Q GPU, latest Samsung 960 nVMe M.2 SSD disks, etc. More interesting maybe is the Windows version: Win 10 Pro v 1803 build 17134.48 (as in the very latest). The install of everything is quite fresh and virginal at this stage, only a month, so no garbage on the system, and I keep data separated from OS partitions.

So, I ran a test on an older Win 7 machine I have, and yes, no problem on that. Your suggestions. I guess I can try to uninstall and reinstall the FastKeys software. To create a completely clean uninstall, any registry entries I should delete?

Cheers,
Cass.
User avatar
Marko
Posts: 812
Joined: Mar 2nd, ’13, 21:02

Post by Marko » May 29th, ’18, 10:23

Hm, so maybe the computer is too fast... ;)
We will perform further tests on different computers and hopefully solve this glitch.

There are no registry changes, you can just reinstall but I doubt this will help.
User avatar
easycass
Posts: 20
Joined: May 24th, ’18, 03:28

Post by easycass » May 29th, ’18, 10:28

So, I just set all my settings the same on my Win 7 machine as on the Win 10, and I can duplicate the issue. I will see if I can narrow down what settings caused it... standby...
User avatar
easycass
Posts: 20
Joined: May 24th, ’18, 03:28

Post by easycass » May 29th, ’18, 10:43

Hi Marko, an obscure one for sure. I found that this problem occurs when I have the setting: Preferences/Functions/Auto-correct/Correct sentence capitals enabled. When I have this option disabled, all is fine... Wanna see if that does it for you?
User avatar
Marko
Posts: 812
Joined: Mar 2nd, ’13, 21:02

Post by Marko » May 29th, ’18, 11:09

I tried but there is no difference on my side, "teh" is always auto corrected to "the".
User avatar
easycass
Posts: 20
Joined: May 24th, ’18, 03:28

Post by easycass » May 29th, ’18, 11:39

Hi Marko,

Okay, so this is going to be a strange one to solve then, yes...? especially since I can duplicate it on two machines, with variation of operating system, hardware and applications, and you cannot... :o

So, how to create some uniformity for testing. If I do a new install, complete reset to the defaults of all the Preferences, remembering to set Text Expander to run Auto Correct English and Auto Complete to run English Common Words, then by changing Preferences/Functions/Auto-correct/Correct sentence capitals, I can get the problem to occur with it set and not occur when not set. Go figure...

If you cannot duplicate it, then no worries, as I can leave this setting off for now. Perhaps another user may see this and spot some other contributing factors.

Many thanks anyway Marko. We'll get there in the end...

Later,
Cass.
User avatar
easycass
Posts: 20
Joined: May 24th, ’18, 03:28

Post by easycass » May 29th, ’18, 18:01

Hi Marko,

A bit more information. Doing some tests on both my systems, I can get it to happen with some various parameters. Here is the summary: -

1) When Preferences/Functions/Auto-correct/Correct sentence capitals is enabled, typing a word that is both 1) the stem of an Auto-Complete entry and 2) an exact match for a Text Expander/Correction entry, then pressing [space] after entering those characters does not apply the Text Expander/Correction entry.
2) If instead of using a [space] to end a word, a symbol like [.] or [,] etc is used, then the text expander entry is applied.
3) This appears to happen on words like teh/the in the Text Expander/Correction and tehran in Auto-Complete, but equally will occur when using words like transi/trains and transister respectively.
4) It does not have to be in a word list or phrase file, but can just be a single entry correction and auto-completion.
5) It occurs using both a Windows 10 and Windows 7 installation, both admin accounts.

I will continue to look for other clues,
Cass.
User avatar
Marko
Posts: 812
Joined: Mar 2nd, ’13, 21:02

Post by Marko » May 30th, ’18, 15:19

Hi Cass,

thanks for testing this. I tried it myself on two computers (Win10 & Win7):
- did fresh FastKeys install,
- enabled Auto Correct English Phrase file and English Common words wordlist,
- enabled Correct sentence capitals feature.

Typing "teh" in Notepad (where do you type?) followed by Space or . or , always results with "the". However typing "teh" followed by Enter results with "Tehran". The result is never "teh".

It looks like the internal priority (TE vs AC) is impacted by enabling mentioned feature and by computer speed (or other characteristics). We will try to test this further and try to optimize.
Post Reply