Ignore accents on search

Suggestions, feature requests and bug reports.
Post Reply
User avatar
gustms
Posts: 103
Joined: Sep 26th, ’14, 21:32

Post by gustms » Apr 13th, ’18, 08:43

Hi, hope this is a good suggestion.

In Portuguese we have a lot of accented words, and the new quick search feature is strictly requiring them for searching. Is it possible to add an option to search both accented and non-accented words, please?

Like, right now searching for rizo shows "horizontal" but not "rizólise". If possible, the same could be done for other accent characters, like â, ã, à, etc.

Thanks a lot in advance.
User avatar
Marko
Posts: 812
Joined: Mar 2nd, ’13, 21:02

Post by Marko » Apr 13th, ’18, 10:15

Absolutely, we will try to update the search routine in one of the next versions.
Thanks! ;)
User avatar
gustms
Posts: 103
Joined: Sep 26th, ’14, 21:32

Post by gustms » Apr 13th, ’18, 14:45

Thank you, Marko!
User avatar
Marko
Posts: 812
Joined: Mar 2nd, ’13, 21:02

Post by Marko » May 7th, ’18, 20:54

This should work in 4.08. :D
User avatar
gustms
Posts: 103
Joined: Sep 26th, ’14, 21:32

Post by gustms » May 8th, ’18, 21:02

Hi Marko, thank you!

Indeed, it is working for some strings. Thanks!

But still have 2 problems to fit my needs, if it is not too troublesome to add, please:

1) It doesn't work for Phrase Files, and, sadly, those are 90% of my expansions.

2) It is not ignoring the character ~, like in õ, which is very common in Portuguese.

If it is possible to add these 2 extra features, it would be even more awesome.

Thanks again in advance.
User avatar
Marko
Posts: 812
Joined: Mar 2nd, ’13, 21:02

Post by Marko » May 9th, ’18, 17:11

1) I tested again and it works for Phrase files. Can you give me an example?
2) I will see for the next version - we should probably include all special international characters...
User avatar
gustms
Posts: 103
Joined: Sep 26th, ’14, 21:32

Post by gustms » May 10th, ’18, 21:10

Hi Marko, thank you for testing. Indeed it is working for phrase files, but apparently it is a problem with different accented letters.

Here is a test file:

Code: Select all

::02::Periapicopatias
::02a::Periapicopatia
::03::Periápices
::03a::Periápice
::08::Periépices
::08a::Periépice
::07::Periípices
::07a::Periípice
::10::Periópices
::10a::Periópice
::11::Periúpices
::11a::Periúpice
::13::Periâpices
::13a::Periâpice
::04::Periêpices
::04a::Periêpice
::09::Periîpices
::09a::Periîpice
::05::Periôpicos
::05a::Periôpico
::12::Periûpices
::12a::Periûpice
::05::Periãpices
::05a::Periãpice
::14::Periõpices
::14a::Periõpice
::06::Periàpices
::06a::Periàpices
From my tests, it does not work for:
á í ó ú ã õ

All the others tested (é â ê î ô û) worked just fine inside a phrase file. The problem was most of my accented expansions are with "á" and "ã", that is why I thought it was related to phrase files. My mistake.

But putting these same expansions as single "send" expansions don't work as well. They only show when the search has the accented letters. Could you please check if you can reproduce it?

Thanks in advance.
User avatar
Marko
Posts: 812
Joined: Mar 2nd, ’13, 21:02

Post by Marko » May 11th, ’18, 22:18

I see, thanks for the testing. We will try adding other special characters into the rule.
User avatar
Marko
Posts: 812
Joined: Mar 2nd, ’13, 21:02

Post by Marko » Jun 5th, ’18, 05:54

This was improved in 4.09. ;)
User avatar
gustms
Posts: 103
Joined: Sep 26th, ’14, 21:32

Post by gustms » Jun 6th, ’18, 08:54

Thank you! Just tested it, and seems to be working great.
Post Reply