pasting to excel changes . to , points to comma

Discussion, questions and support.
Mr.Aky
Posts: 11
Joined: May 21st, ’19, 06:49

Post by Mr.Aky » May 16th, ’20, 06:54

I'm using excel in italian
When copy a text a put the clipboard value into User_1

When I paste i use

Clipboard:=User_1
Sendinput, %Clipboard%

If I copy an email address for example test.test@hotmail.it
If i paste in notepad it is pasted as test.test@hotmail.it
but if I paste to excel it is pasted as test,test@hotmail,it (with commas)


Do you know how to solve this issue ?
User avatar
Marko
Posts: 1175
Joined: Mar 2nd, ’13, 21:02

Post by Marko » May 17th, ’20, 14:49

Have you saved the email address to User variable?
There is no need to use a Clipboard:

Type: Send

Code: Select all

%A_User_1%
Mr.Aky
Posts: 11
Joined: May 21st, ’19, 06:49

Post by Mr.Aky » May 18th, ’20, 08:57

I have changed the variable to %User_1%
but when I paste name.surname@gmail.com in excel (italian) it becomes
name,surname@gmail,com
in notepad it is pasted as name.surname@gmail.com (points are preserved)

Massimo
User avatar
Marko
Posts: 1175
Joined: Mar 2nd, ’13, 21:02

Post by Marko » May 19th, ’20, 20:25

Are you using a text expander? Can you post an image of your setting (abbreviation, substitute)?
Mr.Aky
Posts: 11
Joined: May 21st, ’19, 06:49

Post by Mr.Aky » May 20th, ’20, 07:33

No, I don't use them

https://www.loom.com/share/ce3048ea5812 ... 0c686090fe

As you can see correctly nome.cognome is sent to libreoffice calc but in the cell I see nome,cognome

Do you have any idea why this happens ?
Or I can I solve this problem ?

Massimo
User avatar
Marko
Posts: 1175
Joined: Mar 2nd, ’13, 21:02

Post by Marko » May 20th, ’20, 09:50

Can you post your Shortcut setting and the User variable setting?
Mr.Aky
Posts: 11
Joined: May 21st, ’19, 06:49

Post by Mr.Aky » May 20th, ’20, 11:01

User avatar
Marko
Posts: 1175
Joined: Mar 2nd, ’13, 21:02

Post by Marko » May 20th, ’20, 11:42

I mean where is the Alt+1 shortcut you use defined? And where is User_7 variable defined?
Mr.Aky
Posts: 11
Joined: May 21st, ’19, 06:49

Post by Mr.Aky » May 21st, ’20, 06:33

Copy shotcut
ClipBoard:=""
Send ^c
ClipWait
Clipboard=%Clipboard%
Sleep, 200
User_1 := ClipBoard

Paste shortcut
Sendinput, %User_1%

A copy of nome.cognome@test.it in excel produces nome,cognome@test,it
If instead of Sendinput, %User_1% I use Send ^v it pastes correctly nome.cognome@test.it .
Why this happens ?
And why the problem is only in excel ?

Massimo
User avatar
Marko
Posts: 1175
Joined: Mar 2nd, ’13, 21:02

Post by Marko » May 21st, ’20, 20:12

Why are you complicating? If all you want is pasting clipboard content without formatting then you only need this paste shortcut:

Code: Select all

clipboard=%clipboard%
sleep 100
Send, ^v
Post Reply