Auto website login?

Discussion, questions and support.
Post Reply
benzol
Posts: 2
Joined: Mar 25th, ’20, 14:38

Post by benzol » Mar 25th, ’20, 14:50

Hello, I'm really new to FastKeys but quite like it so far and just ordered a personal edition.

I would like to create a command for opening a website and fill in username and password and hit login. I used the following script but it only opened the website without doing the following steps. I wonder if anyone could help me out here? Thank you!

Code: Select all

Run, https://www.editorialmanager.com/advenergymat/default.aspx
WinWait, , Username,
sleep, 1000
Send, {Tab 3}usename{Tab}password{Tab 4}{Enter}
(the last {Tab 4} is to specify logging in through "Editor login")
User avatar
Marko
Posts: 1127
Joined: Mar 2nd, ’13, 21:02

Post by Marko » Mar 26th, ’20, 21:45

WinWait is not useful as the page still needs to load - try experimenting with the Sleep length.
This works for me:

Code: Select all

Run, https://www.editorialmanager.com/advenergymat/default.aspx
sleep, 4000
Send, {Tab 2}usename{Tab}password{Tab 4}{Enter}
benzol
Posts: 2
Joined: Mar 25th, ’20, 14:38

Post by benzol » Mar 27th, ’20, 04:37

Thank you Marko, this worked!
Marko wrote:
Mar 26th, ’20, 21:45
WinWait is not useful as the page still needs to load - try experimenting with the Sleep length.
This works for me:

Code: Select all

Run, https://www.editorialmanager.com/advenergymat/default.aspx
sleep, 4000
Send, {Tab 2}usename{Tab}password{Tab 4}{Enter}
Post Reply