Autocomplete and Enter-Key

Discussion, questions and support.
Post Reply
albatross
Posts: 16
Joined: Nov 17th, ’19, 20:33

Post by albatross » Dec 24th, ’19, 12:35

Hi,

I'm currently struggling with the autocomplete functionality / options.

I want to have the following behaviour:
Only if I press the hotkey combination defined in the autocomplete options- then the proposal shall be shown.

Currently - the proposals are always shown and any time I hit the space key or the enter key my orig. txt is replaces (and I don't want to do that).

Is there a possibility to change the behaviour to my belongings ?
(no autocompletion if hitting the space or return/enter key and only the autocomplete hotkey shows the proposals ...)?

Maybe I did some mistakes within the option fields - see below

Thanks in advance.
albatross

P.S: Just a hint - I don't want to deactiviate the autocomplete functionality totaly - it should be there - if I hid the defined hotkeys.
P.S.S: Using Fastkey 4.23 and 4.24
P.S.S.S: As I do not know how to upload an image .. here the optionvalues of the autocomplete menu

Auto complete
Minimum wrd lenght: 3
Word suggestion list heigh: 10

Options: ONLY the tagged once
Send raw text
Automatic spacing

Shortcut
CTRL+Space

Restrictions: .. none..
User avatar
Tom
Posts: 398
Joined: Nov 24th, ’15, 23:39

Post by Tom » Dec 25th, ’19, 12:57

To set Auto Complete to full manual control, make the following settings:

Minimum word length to show suggestion - Set this option to 0 to disable automatic suggestions.
Shortcut - Set a keyboard shortcut to manually open auto complete suggestion window.

Also check the Selection keys in Preferences/General/Appearance.
albatross
Posts: 16
Joined: Nov 17th, ’19, 20:33

Post by albatross » Dec 25th, ’19, 13:42

Hello Tom,

as suggested, I set

* Preferences / Autocomplete / sugestion: 0
* Preferences / Autocomplete / options: send raw text
* Preferences / Autocomplete / shortcut- Shos suggestion: Ctrl+Space
-------------------
* Preferences / General / Appearance: Selection key: all selectec - except Numpad
* alternative test: untagged return and space key.... ...no
-------------------
Autocomplete-Tab: Run English common words.

Behaviour is still the same:
* Autocomplete proposal appears automatically
* return takes over the proposal of fastkeys first item in the list

What needs to be changed additionaly ?
kr
albatross
User avatar
Tom
Posts: 398
Joined: Nov 24th, ’15, 23:39

Post by Tom » Dec 25th, ’19, 18:50

I tried with the same settings and auto complete never shows automatically. Do you perhaps see a Text Expander popup?
albatross
Posts: 16
Joined: Nov 17th, ’19, 20:33

Post by albatross » Dec 25th, ’19, 22:45

Hi Tom,

I'm not realy sure …

I think it is the autocomplete window -
as the proposals for english (usual) words like 'This' or 'agree' are shown.

Is there a possiblity to provide screenshots ?

kind regards
albatross

P.S:
English common words are not listed if the TextEspander box is displayed via shortcut.
User avatar
Tom
Posts: 398
Joined: Nov 24th, ’15, 23:39

Post by Tom » Dec 26th, ’19, 10:55

Based on your other posts I assume you may have two instances running at the same time - please check the Tray icons and Task Manager.
albatross
Posts: 16
Joined: Nov 17th, ’19, 20:33

Post by albatross » Dec 28th, ’19, 15:47

Hello Tom,

I did a check in the Taskmanager / Processes.
Only one instance of Fastkeys is executing.
User avatar
Tom
Posts: 398
Joined: Nov 24th, ’15, 23:39

Post by Tom » Dec 28th, ’19, 18:49

You can send your settings.fdb and settings.ini files to our support mail and we will check.
albatross
Posts: 16
Joined: Nov 17th, ’19, 20:33

Post by albatross » Jan 2nd, ’20, 18:25

thanks for the offer...

done
Post Reply