How to limit a shortcut to a specific program/window?

Discussion, questions and support.
Post Reply
eselick
Posts: 25
Joined: Oct 19th, ’14, 13:28

Post by eselick » Jan 18th, ’16, 02:58

Hi
I'm sure there are examples for this but I'm haven't found any.
As a workaround for the mouse wheel problem I'm having I've reprogrammed the wheel up/dn to send the letter O which is used for the Orbit command in Sketchup. That is the only program where this should take place otherwise I'm getting random "o" all over the place.

Currently my shortucut "send"s {Shift}+O.
What changes would I need to turn this off this behavior outside of Sketchup?

Thanks
User avatar
Ennovy
Posts: 59
Joined: Mar 18th, ’14, 08:46

Post by Ennovy » Jan 18th, ’16, 08:29

You might want to read this: https://autohotkey.com/docs/commands/_IfWinActive.htm
To create a command that only works in Sketchup

The other way around:
You can also create a command that works everywhere but not in for instance Total Commander:
User avatar
Marko
Posts: 1205
Joined: Mar 2nd, ’13, 21:02

Post by Marko » Jan 18th, ’16, 12:32

In FastKeys you can use Window option to limit the shortcut to only be active in specified application or window. In your case set Window to "Sketchup". Alternatively you can use Tools/Window Information to get the correct Sketchup window name.
eselick
Posts: 25
Joined: Oct 19th, ’14, 13:28

Post by eselick » Jan 19th, ’16, 00:54

Thanks - That worked great.
Post Reply