RButton as Gesture Key

Discussion, questions and support.
Post Reply
NW5o4vTsxVyAY4AY
Posts: 26
Joined: Feb 5th, ’19, 14:11

Post by NW5o4vTsxVyAY4AY » Dec 2nd, ’21, 18:22

Hi,

I'm using RButton as my Gesture Key, without any modifiers, and it's working as intended most of the time.
However, sometimes I notice that my FastKeys scripts in general (so not just gestures, but also shortcuts, text expander, etc) 'get stuck', meaning that they don't work until I click my right mouse button again somewhere.

Is this something that's expected to happen when using only the RButton without any modifiers, or is there something I can do to prevent this?


Thanks in advance.
User avatar
Marko
Posts: 1460
Joined: Mar 2nd, ’13, 21:02

Post by Marko » Dec 4th, ’21, 15:02

There should be no difference, either should work. Does this happen in a specific application?
NW5o4vTsxVyAY4AY
Posts: 26
Joined: Feb 5th, ’19, 14:11

Post by NW5o4vTsxVyAY4AY » Dec 6th, ’21, 01:50

I mostly use gestures in my browsers, so Firefox for example.

But I did some more testing and found out this only happens when using gestures in combination with a FastKeys start menu. Let me explain:

So I have a start menu that's opened with Win + F2. The entries in that menu open new pages/tabs in my browser.
When I open that menu via my keyboard and click one of the entries to open a new page/tab, my text expander scripts and rest of FastKeys work as intended on that new page.

The problem only occurs when I open this menu with a gesture (I use Left gesture) using this command (something I picked up in this topic)

SendLevel 1
Send #{F2}
SendLevel 0
return

In that case, about 50% of the time, my text expander scripts and rest of FastKeys won't work on the new page until I click my right mouse button at least once.

So something is wrong when using a gesture to open a FastKeys start menu this way.

Let me know if you need more info about my settings or scripts.
User avatar
Tom
Posts: 600
Joined: Nov 24th, ’15, 23:39

Post by Tom » Dec 6th, ’21, 19:31

It looks like this hack has undesirable effects. Maybe try adding the following lines after SendLevel 0

Sleep 100
Send, {RButton Up}
NW5o4vTsxVyAY4AY
Posts: 26
Joined: Feb 5th, ’19, 14:11

Post by NW5o4vTsxVyAY4AY » Dec 11th, ’21, 14:56

Thanks for your reply.
Unfortunately this doesn't help, the behavior is the same.

I also realized that this doesn't really have to do with the start menu or SendLevel, it's just a problem with gestures in general.

Let's assume I'm on a page in Firefox, let's call it "page one".
With a Right gesture I open a new tab, using this command

Send {Ctrl Down}t{Ctrl Up}
return

This works as intended 100% of the time.

With an Up gesture I close that new tab again, using this command

Send {Ctrl Down}w{Ctrl Up}
return

This also works as intended 100% of the time.

However, now that I'm back on "page one" and without pressing my right mouse button (gesture key), using Right gesture opens the new tab alright, but on that new page Fast Keys stops working about half of the time until I press my right mouse button again.
So something about using gestures in succession like this causes the problem. It's not caused when using a shortcut to open the tab instead.

The reason this is an issue for me and why I noticed it in the first place is because I often use my start menu to search a selected word on a different page, close that page and then search the same selection on yet another page.

I don't think it matters, but here are my gesture settings (standard I think):

Interval (ms) - 40
Threshold (px) - 25
Timeout (ms) - 500
Initial timeout (ms) - 250
Tolerance (%) - 100
User avatar
Tom
Posts: 600
Joined: Nov 24th, ’15, 23:39

Post by Tom » Dec 12th, ’21, 10:59

NW5o4vTsxVyAY4AY wrote:
Dec 11th, ’21, 14:56
However, now that I'm back on "page one" and without pressing my right mouse button (gesture key), using Right gesture opens the new tab alright, but on that new page Fast Keys stops working about half of the time until I press my right mouse button again.
Sorry I cannot reproduce this. What do you mean by "FastKeys stops working"? Could you explain step by step?
Also, try first to reset the Gestures Preferences to defaults to see it this helps.
It could also be a specific combination of scripts you are using - in this case it would be better to contact your support mail.
NW5o4vTsxVyAY4AY
Posts: 26
Joined: Feb 5th, ’19, 14:11

Post by NW5o4vTsxVyAY4AY » Dec 12th, ’21, 13:29

It's like I wrote in my first post, any FastKeys functions like shortcuts or text expander won't trigger, they only work normally again after I press my right mouse button (gesture key).

And I'm also using the default gesture settings. I even tried it with "factory settings" by completely resetting FastKeys.

I recorded a short video to show what it looks like, maybe it's easier this way: https://sendvid.com/6e8leg1p.

In this video I only perform three actions with simple scripts. I don't have any other scripts running:

1. Using Right gesture to open a new tab ("Firefox Home" page).
Command:

Code: Select all

Send {Ctrl Down}t{Ctrl Up}
return
2. Entering the text expander string test1 in the address bar to show that FK is working as intended.
Command/text:

Code: Select all

FK works.
3. Using Up gesture to close the tab.
Command:

Code: Select all

Send {Ctrl Down}w{Ctrl Up}
return
I repeat this three times. As you can see, the first two times everything works as intended.
However, the third time is when the issue occurs, as entering test1 doesn't trigger the "FK works" text.

Using the text expander here is just an example, but the behavior is the same with shortcuts.

I really don't know what could be causing this, as the actions and conditions are the same each time.
Last edited by NW5o4vTsxVyAY4AY on Dec 16th, ’21, 15:01, edited 1 time in total.
User avatar
Tom
Posts: 600
Joined: Nov 24th, ’15, 23:39

Post by Tom » Dec 12th, ’21, 16:15

Thanks for the video. I tried to replicate this with the same exact commands but it works for me every time. There must be something else, could you contact us on our email to explore it further?
Post Reply