Question: Double period at end of a string?

Discussion, questions and support.
Post Reply
gbotes
Posts: 13
Joined: Jul 13th, ’18, 13:45

Post by gbotes » Oct 8th, ’20, 13:06

Please pardon me if this is an ignorant question. I note that I can create an expansion string like dtme,, but not dtme..

That is, my text expansion string can terminate with a double comma but not with a double period. Is there a reason why I cannot terminate a text expansion string with a double period?

In this example, I have the text expansion phrase dtme,, which must expand to the substitution phrase %A_Now% GB:
and is set to trigger immediately. It works fine with dtme,, but not with dtme..
User avatar
Tom
Posts: 416
Joined: Nov 24th, ’15, 23:39

Post by Tom » Oct 8th, ’20, 15:43

The period (or a full stop) is one of the default ending characters which trigger the substitution. If you wish, you can remove the period from the list of ending characters in Preferences/Text Expander.
gbotes
Posts: 13
Joined: Jul 13th, ’18, 13:45

Post by gbotes » Oct 9th, ’20, 05:42

I see. But , is also in the list of default ending characters and a double comma works fine. My question was more about me wanting to understand FastKeys better rather than to fill a need. I can use ,, instead of .. But I was just curious to know why ,, works but .. doesn't. Your answer doesn't seem to explain it. And removing . from the list made no difference to this FastKeys behaviour.
User avatar
Tom
Posts: 416
Joined: Nov 24th, ’15, 23:39

Post by Tom » Oct 9th, ’20, 16:04

Sorry, you are right, this is not related to ending characters. Both should work with simple text expansion.
However when "Display suggestions as you type" option is enabled in Preferences/Text Expander, the period resets the recognition of the entered word. Is this your case?
Last edited by Tom on Oct 12th, ’20, 11:53, edited 1 time in total.
gbotes
Posts: 13
Joined: Jul 13th, ’18, 13:45

Post by gbotes » Oct 12th, ’20, 11:43

Yes, that is the case. Display suggestions as you type is enabled. Thank you very much - your explanation makes it clear now.
Post Reply